Unhautorized (permission denied) when using wget from Windows

  • Question
  • Updated 2 years ago
  • Doesn't Need an Answer
Hi,

we have a PVCS VM test environment installed on a server with WebDav enable, and the ServerDB is reachable at the following address on the intranet

http://hqwdvvermgr1.hq.un.fao.org:808...

We managed to have BitKinex (a windows WebDav client with a graphical interface) connect to the above and list, open, checkout/in files etc.

We are now trying with wget (a command line client for windows) I keep on getting a permission denidied error.

I raise the following command

wget --no-check-certificate --user= --password= http://hqwdvvermgr1.hq.un.fao.org:808...

and I get the following message

SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
syswgetrc = C:\Program Files\GnuWin32/etc/wgetrc
--2012-03-02 16:48:29-- http://hqwdvvermgr1.hq.un.fao.org:808...
Resolving hqwdvvermgr1.hq.un.fao.org... 168.202.4.249
Connecting to hqwdvvermgr1.hq.un.fao.org|168.202.4.249|:8080... connected.
HTTP request sent, awaiting response... 401 Unauthorized
Reusing existing connection to hqwdvvermgr1.hq.un.fao.org:8080.
HTTP request sent, awaiting response... 200 OK
Length: 5327 (5.2K) [text/html]
chessviewer.html: Permission denied

Cannot write to `chessviewer.html' (Permission denied).

giovanni.stoto

  • 17 Posts
  • 0 Likes
  • frustrated

Posted 2 years ago

  • 1

giovanni.stoto

  • 17 Posts
  • 0 Likes
Problem solved thanks
I was issuing the wget command from a local folder where I had no write access

Jeanie Swan

  • 109 Posts
  • 11 Likes
Thank you for letting us know you resolved it. That is not a WebDAV client that I've worked with, so I wasn't sure what to expect. I've pretty much played with the ones we have as officially supported clients (from the Readme) so we would have had to try to get some logging to troubleshoot.